Archivos CSV y Excel

Cómo trabajar con archivos CSV en Microsoft Excel

Al usar Microsoft® Excel® para manejar archivos CSV a fin de usarlos con BEACON, no abra el archivo simplemente haciendo doble clic en él. En su lugar, use la función Data>From Text (Datos>Desde texto) (Windows) o la función File>Import (Archivo>Importar) (Mac OS) para pasar el archivo CSV a Excel. Esto ayuda a preservar la fidelidad de sus datos.

Al usar este método, un Import Wizard (Asistente de importación) le permite elegir un delimitador y determinar cómo tratar los datos, como los números y las fechas, en su archivo. Establecer todos los datos como Texto evita que los números largos se muestren como valores de punto flotante, que se eliminen los ceros iniciales y finales, y que las fechas se muestren en formatos que no cumplen con la norma ISO.


¡IMPORTANTE! Cuando se pasan archivos de Data Exchange a BEACON de forma regular, es esencial que se mantenga la fidelidad de los datos entre las importaciones. Por ejemplo, si abre un archivo en Excel haciendo doble clic en él, Excel eliminará los ceros iniciales o finales en cualquier campo que los use. Aunque eso podría parecer poco importante para la configuración de Resolución de registro como 0.01, es fundamental para los identificadores (ID) de cuenta, los ID de ubicación y los ID de medidor, por ejemplo 000123456. Para BEACON, el ID de cuenta 123456 y el ID de cuenta 000123456 representan dos cuentas diferentes. Si una importación incluye ceros a la izquierda y una importación futura no los incluye, los datos del medidor se enrutarán incorrectamente. Este efecto puede amplificarse si se utilizan diferentes herramientas para manejar archivos de Data Exchange en formato CSV. Por ejemplo, este visualizador y editor de CSV en línea no eliminará los ceros iniciales o finales, mientras que Excel sí puede hacerlo y lo hará si se usa de manera incorrecta.
Como resultado, preste mucha atención a las advertencias generadas por el proceso de sincronización del sistema.


Para usuarios de Windows:

Siga estos pasos para importar archivos CSV a Excel:

  1. Seleccione File>New (Archivo>Nuevo) para crear un nuevo archivo.

    importar

  2. Seleccione Data>From Text (Datos>Desde texto).

    desde-texto

  3. Busque y seleccione el archivo que desea importar usando el sistema de archivos de su computadora.
  4. En el menú emergente del Text Import Wizard (Asistente de importación de texto), haga clic en el botón de opción CSV, establezca el File Origin (Origen de archivo) como Unicode (UTF-8) y haga clic en Next (Siguiente).

    importar-8

  5. Establezca el Delimiter (Delimitador) y haga clic en Next (Siguiente).

    importar-4

  6. Pulse Shift (Mayús) y haga clic en todas las columnas para seleccionarlas. Haga clic en el botón de opción Texto para configurar el formato de datos del archivo y haga clic en Finish (Terminar).

    importar-9

  7. Establezca dónde desea colocar los datos con el botón de opción correspondiente y haga clic en OK (Aceptar).

    importar-6

Cuando se complete el proceso de importación, las fechas estarán en el formato correcto, se conservarán los números que contienen ceros a la izquierda y los números largos no se convertirán en valores de punto flotante.

Para usuarios de Mac OS:

Siga estos pasos para importar archivos CSV a Excel:

  1. Seleccione File>New Workbook (Archivo>Nuevo libro de trabajo) para crear un nuevo archivo.
  2. Seleccione File>Import (Archivo>Importar).

    excel-importar-archivo

  3. En el menú emergente Import (Importar), seleccione el botón de opción CSV file (Archivo CSV) y haga clic en Import (Importar).

    csv-botón-de-opción

  4. Busque el archivo que desea importar utilizando el sistema de archivos de su computadora y haga clic en Get Data (Obtener datos).
  5. En el Text Import Wizard (Asistente de importación de texto), asegúrese de que el botón de opción Delimited (Delimitado) esté seleccionado y establezca el File Origin (Origen del archivo) como Unicode (UTF-8).

    captura-de-pantalla-2017-02-08-a-las-10-07-30-am

  6. Haga clic en Next (Siguiente).
  7. Establezca los Delimiters (Delimitadores) y haga clic en Next (Siguiente).

    captura-de-pantalla-2017-02-08-a-las-10-07-45-am

  8. Pulse Shift (Mayús) y haga clic en todas las columnas para seleccionarlas. Haga clic en el botón de opción Texto para configurar el formato de datos del archivo y haga clic en Finish (Terminar).

    captura-de-pantalla-2017-02-08-a-las-10-08-12-am

  9. Establezca dónde desea colocar los datos con el botón de opción correspondiente y haga clic en OK (Aceptar).

    ubicación

 
Cuando se complete el proceso de importación, las fechas estarán en el formato correcto, se conservarán los números que contienen ceros a la izquierda y los números largos no se convertirán en valores de punto flotante.

Knowledge Base

User Guide
Follow via Email

Enter your email address to get new content notifications by email.

A %d blogueros les gusta esto: