System Requirements Update

Badger Meter recommends that all users keep their internet browsers up to date and secure by utilizing automatic update services. Also note that as Microsoft is phasing out Internet Explorer (IE 11) and early versions of Edge, BEACON AMA will no longer be updated to support IE 11 or Edge versions prior to Chromium. Updated technical requirements are here.

Was this post helpful?

Senior Documentation Specialist, Badger Meter

Posted in BEACON, What's New

Get Support

Knowledge Base

User Guide
Follow via Email

Enter your email address to get new content notifications by email.